Topology

topology

Cable the network as shown in the topology

IP Address Table

DeviceInterfaceIP/Network AddressSubnet MaskDefault Gateway
R1L0209.165.10.1255.255.255.0N/A
G0/0172.16.0.1255.255.255.0N/A
S0/0/0192.168.10.2255.255.255.252N/A
S0/0/1192.168.10.6255.255.255.252N/A
R2L5200.100.11.1255.255.255.192N/A
L6200.100.11.65255.255.255.192N/A
L7200.100.11.129255.255.255.224N/A
G0/0.10172.16.1.1255.255.255.128N/A
G0/0.20172.16.1.129255.255.255.192N/A
S0/0/0192.168.10.1255.255.255.252N/A
S0/0/1192.168.10.9255.255.255.252N/A
R3L8200.100.12.1255.255.255.128N/A
L9200.100.12.129255.255.255.192N/A
L10200.100.12.193255.255.255.224N/A
G0/0.30172.16.2.1255.255.255.192N/A
G0/0.40172.16.2.65255.255.255.224N/A
S0/0/0192.168.10.10255.255.255.252N/A
S0/0/1192.168.10.5255.255.255.252N/A
S1Int vlan 1172.16.0.2255.255.255.0N/A
S2Int vlan 1172.16.1.194255.255.255.224N/A
S3Int vlan 1172.16.2.129255.255.255.240N/A
PC1NIC172.16.1.3255.255.255.128172.16.1.1
PC2NIC172.16.1.131255.255.255.192172.16.1.129
PC3NIC172.16.2.3255.255.255.192172.16.2.1
PC4NIC172.16.2.67255.255.255.224172.16.2.65
PC5NIC172.16.0.4255.255.255.0172.16.0.1

Device Configs

R1 Configs

hostname R1
no ip domain-lookup

enable secret class
line console 0
  password cisco
  logging synchronous
  login
line vty 0 4
  password cisco
  login
banner motd ^ Unauthorized access is prohibited. ^

interface Loopback0
ip address 209.165.10.1 255.255.255.0

interface GigabitEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 192.168.10.2 255.255.255.252
!
interface Serial0/0/1
 ip address 192.168.10.6 255.255.255.252
 clock rate 2000000

router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute static subnets 
 passive-interface GigabitEthernet0/0
 network 192.168.10.0 0.0.0.3 area 0
 network 192.168.10.4 0.0.0.3 area 0
 network 172.16.0.0 0.0.0.255 area 0
 default-information originate
!
ip route 0.0.0.0 0.0.0.0 Loopback0 

R2 Configs


hostname R2

no ip domain-lookup
enable secret class
line console 0
  password cisco
  logging synchronous
  login
line vty 0 4
  password cisco
  login
banner motd ^ Unauthorized access is prohibited. ^

interface Loopback5
 ip address 200.100.11.1 255.255.255.192
!
interface Loopback6
 ip address 200.100.11.65 255.255.255.192
!
interface Loopback7
 ip address 200.100.11.129 255.255.255.224
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 172.16.1.1 255.255.255.128
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.16.1.129 255.255.255.192

interface Serial0/0/0
 ip address 192.168.10.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.10.9 255.255.255.252

router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 passive-interface GigabitEthernet0/0.1
 passive-interface GigabitEthernet0/0.10
 passive-interface GigabitEthernet0/0.20
 network 192.168.10.0 0.0.0.3 area 0
 network 192.168.10.8 0.0.0.3 area 0
 network 200.100.11.0 0.0.0.63 area 0
 network 200.100.11.64 0.0.0.63 area 0
 network 200.100.11.128 0.0.0.31 area 0
 network 172.16.1.0 0.0.0.127 area 0
 network 172.16.1.128 0.0.0.63 area 0
 network 172.16.1.192 0.0.0.31 area 

R3 Configs

hostname R3

no ip domain-lookup
enable secret class
line console 0
  password cisco
  logging synchronous
  login
line vty 0 4
  password cisco
  login
banner motd ^ Unauthorized access is prohibited. ^
!
interface Loopback8
 ip address 200.100.12.1 255.255.255.128
!
interface Loopback9
 ip address 200.100.12.129 255.255.255.192
!
interface Loopback10
 ip address 200.100.12.193 255.255.255.224
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 172.16.2.1 255.255.255.192
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 172.16.2.65 255.255.255.224

interface Serial0/0/0
 ip address 192.168.10.10 255.255.255.252
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.10.5 255.255.255.252

router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 passive-interface GigabitEthernet0/0
 passive-interface GigabitEthernet0/0.1
 passive-interface GigabitEthernet0/0.30
 passive-interface GigabitEthernet0/0.40
 network 192.168.10.4 0.0.0.3 area 0
 network 192.168.10.8 0.0.0.3 area 0
 network 200.100.12.0 0.0.0.127 area 0
 network 200.100.12.128 0.0.0.63 area 0
 network 200.100.12.192 0.0.0.31 area 0
 network 172.16.2.0 0.0.0.63 area 0
 network 172.16.2.64 0.0.0.31 area 0
 network 172.16.2.128 0.0.0.15 area 0

S1 Configs

hostname S1
no ip domain-lookup

interface Vlan1
 ip address 172.16.0.2 255.255.255.0

S2 Configs

hostname S2
no ip domain-lookup

interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode trunk
interface Vlan1
 ip address 172.16.1.194 255.255.255.224
!

S3 Configs

hostname S3
no ip domain-lookup
!
interface FastEthernet0/5
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 40
 switchport mode access
!
interface GigabitEthernet0/1
 switchport mode trunk

interface Vlan1
 ip address 172.16.2.129 255.255.255.240